Системные требования для CMS Joomla (Джумла) 1.5 / 1.6 / 1.7 / 2.5

System requirements Joomla and WordPress

В этой небольшой статье мне бы хотелось затронуть тему системных требований для такой знаменитой системы управления контентом c открытым кодом Joomla. Какие нужны системные требования joomla 2.5, а какие нужны для joomla 1.5, какое программное обеспечение и каких версий необходимо, чтобы вы смогли спокойно установить Джумлу. Обо все об этом читайте в этой статье.

 


Системные требования joomla 2.5, 1.7, 1.6, 1.5

Уважаемые читатели Ageta.ru, Joomla не такая требовательная в своих технических ресурсах и на большинстве платных и бесплатных хостинг-площадках CMS будет работать без проблем и специальных настроек. Самое главное, чтобы хостер поддерживал PHP и MySQL. Можете обратить внимание на соответствие версий, но в большинстве случаев в этом нет необходимости.

Системные требования для CMS Joomla 2.5

Во время установки Jooml’ы, проверяется на соответствия и информирует об этом.

Joomla оптимизирована для работы под управлением веб-сервера Apache, но может работать и на других серверах. Для функционирования системы управления контентом Joomla сервер должен обязательно быть оборудован СУБД My SQL. Это обязательное условие, потому как поддерживается только эта система управления базами данных. CMS Joomla написан на языке PHP и поэтому для работы Joomla 1.5, 1.6, 1.7, 2.5, чтобы на сервере хостера был обязательно установлен интерпретатор PHP с включенной поддержкой MySQL, XML и ZLib.

Для эффективного функционирования системы Joomla необходимо соответствовать следующим требованиям:

Системные требования для Joomla 2.5.x, 1.7.x и 1.6.x

Программное обеспечение

Рекомендованные системные требования

Минимальные системные требования

Более подробная информация

PHP

5.3 +

5.2.4 +

http://www.php.net

MySQL

5.0.4 +

5.0.4 +

http://www.mysql.com

Apache (с mod_mysql&mod_xml&mod_zlib)

+ 2.x

+ 2.x

http://www.apache.org

Microsoft IIS

7

7

http://www.iis.net

Системные требования для Joomla 1.5.x

Программное обеспечение

Рекомендованные системные требования

Минимальные системные требования

Более подробная информация

PHP*

5.2 +

4.3.10

http://www.php.net

MySQL**

4.1.х +

3.23

http://www.mysql.com

Apache ***(с mod_mysql&mod_xml&mod_zlib)

+ 2.x

1.3

http://www.apache.org

Microsoft IIS****

7

6

http://www.iis.net

*Не используйте PHP 4.3.9, 4.4.2 или 5.0.4. Эти релизы известны своими ошибками, которые будут мешать установке. Zend Optimizer 2.5.10 для PHP 4.4.x, также имеет серьезные ошибки.

** Joomla еще не совместима с MySQL 6.x.

*** Для того, чтобы использовать SEO URL, вы должны иметь расширение Apache mod_rewrite установлен.

**** Для Microsoft IIS (в зависимости от настроек)

Официальный сайт о технических требованиях к Joomla

 

Итог

На вашем месте, я бы сильно не вдавался в эти подробности, тем более если вы новичок в этом деле. Важно, чтобы хостинг провайдер поддерживал PHP и MySQL. Если эти условия совпадаю, то с большой долей вероятности у вас ваша Джумла установиться, легко запуститься и будет долго радовать вас. Так как версии PHP и MySQL периодически обновляются и провайдеры следят за этим. Зачастую они даже пишут на своих сайтах, что они поддерживаю системы управления контентом и перечисляют основные из них.

Желаю удачи Вам в освоение Джумлы.

Поделитесь своим мнением
Для оформления сообщений Вы можете использовать следующие тэги:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>